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Matlab Plots in Microsoft Word 

1 Introduction 

This report looks at different options for inserting plots generated from Matlab1 into Micro-

soft Word2 document. For publication quality output, it is important to control the size of the 

graphic that will appear in the final document. The graphic should be drawn at its final size in 

Matlab. Scaling in Word is undesirable, as it not only scales the plot, but also the text on the 

graphic. This report outlines a procedure that sets the size of the figure and the font size in Mat-

lab. Once set, the graphic can be imported into Word with no further scaling. 

Results indicate that the PostScript format is the best option for good quality graphics. 

Graphics imported using cut and paste from Matlab (EMF or bitmap format) are noticeably infe-

rior in quality. 

This report is an update of an earlier one from 2000 [1]. This earlier report documented 

problems with undesired scaling of graphics when they were imported into Word. This problem 

no longer occurs with the updated versions of Matlab and Word considered in the present report. 

Also since the time of the earlier report, Word has acquired the ability to produce a preview of 

PostScript graphics, obviating the need to include a preview while saving PostScript files from 

Matlab. 

                                                      

1 Matlab 7.1 running under Windows XP SP2 was used for these tests. 

2 Microsoft Word 2003 SP2 running under Windows XP SP2 was used for these tests. 



Matlab Plots in Microsoft Word  3 

2 Matlab Units 

Matlab plots consist of a “figure” box containing an “axes” box. The figure are positioned 

with respect to the screen and the axes are positioned with respect to the figure. These rectangles 

are specified with four parameters: [ . The parameters of the rectangles 

can be expressed in several different units. 

]left bottom width height

• Absolute units: These are inches, centimetres and points (72 points to an inch). 

• Screen units (pixels): The screen is sized as pix pix1 1 x y⎡ ⎤⎣ ⎦ . For instance for a 1280 

by 1024 pixel screen display, pixx  is 1280 and  is 1024. Experiments show that pixel 

units at all screen resolutions are converted to absolute units using the conversion 96 pixels 

equal 1 inch

pixy

3. For a so-called 17-inch (diagonal) display (about 12.75 inches horizontally), 

the actual resolution is about 100 pixels/inch for a 1280×1024 resolution. 

• Relative units: Relative values are numbers from 0 to 1. For the figure box,. dimensions are 

relative to the full screen size. For the axes box, dimensions are relative to the containing 

figure box. 

The Matlab routine used to create the sample plots in this report explicitly sets the Matlab 

figure and axes sizes to the final sizes as they will appear in the Word document. The Matlab rou-

tine also sets the font type and font size to that which will appear in the Word document. 

                                                      

3 The 96 pixels/inch corresponds to the “Normal size” DPI setting in the Windows XP Display Prop-

erties settings (Settings tab > Advanced button > General tab). 
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3 Matlab Plot Output Formats 

Here we consider three types of output: PostScript format, Enhanced Metafile (EMF) format, 

and Bitmap format. The PostScript format is appears in an encapsulated PostScript File4. The 

EMF format or Bitmap output can be copied to the Windows clipboard and then can be pasted 

into a Word document. They can also be saved to EMF or BMP files. 

3.1 PostScript Files 

When an encapsulated PostScript file is inserted into a Word document, recent versions of 

Word (with the optional Encapsulated PostScript graphics filter installed) displays a low resolu-

tion preview of the graphic. When the document is printed, the full resolution graphic is printed. 

Matlab optionally allows for a tiff preview to be included in the PostScript file. For more re-

cent versions of Word, the preview is undesirable. The observed behaviour of PostScript files in 

Word is at variance with the documentation in Word. That documentation describes the situation 

that existed in earlier versions of Word, see [1]. The current version of Word behaves as follows: 

• If the PostScript file does not include a preview, Word generates a preview which appears 

on the screen. The full resolution graphic (not the generally low resolution preview) is 

printed, even on non-PostScript printers. This behaviour contradicts the documentation in 

http://support.microsoft.com/?kbid=290362. 

• If the PostScript file includes a preview, Word uses that preview for the screen and also 

uses that preview when printing on non-PostScript printers. The full resolution graphic ap-

pears only on PostScript printers. 

It is prudent to convert the Word document to PDF format (using Adobe Acrobat or any of 

the many free PDF converters based on Ghostscript) to ensure high quality rendition of graphics 

both on the screen and on all printers. Otherwise, printing the Word document from an older ver-

sion of Word may result in poor or o rendition of the PostScript graphics. 

                                                      

4 The encapsulated PostScript format is a graphics interchange format that includes “bounding box” 
information to allow the receiving document to reserve the requisite space for the graphic. 

http://support.microsoft.com/?kbid=290362
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3.2 Enhanced Metafile Format 

The Extended Metafile (EMF) format is used in Microsoft Windows to exchange graphics. 

Matlab provides for the figure to be copied to the clipboard in EMF format. The clipboard con-

tents can then be pasted into the Word document. The graphic can also be saved as an EMF file 

using the Save As command. 

3.3 Bitmap Format 

Matlab offers several options for exporting the graphic in bitmap form. The Matlab plot can 

be copied to the clipboard as a bitmap. This format that is not capable of handling transparency. 

The graphic can also be saved as a bitmap in a BMP file using the Save As command. There are 

other bitmap formats available in Matlab, notably the PNG (Portable Network Graphics) file for-

mat. This format does support transparency and compresses the bitmap. For the examples in this 

document, the PNG file is 30 times smaller than the (uncompressed) BMP file. 
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4 Including Matlab Graphics in Word 

In the case of graphics files, the Insert Picture command places them in the document. For 

graphics copied to the clipboard, the Paste command places them in the document. Appendix A 

gives details of the procedure used to encapsulate the graphic in the Word document. 

Consider the Matlab script shown in Fig. 1. The font size are set to the size that will appear 

in the Word document. The figure box size is set to 10 cm × 8 cm and the axes box size in the plot 

is set to 8 cm × 6 cm. The PaperPositionMode is set to auto to ensure that there is no scaling of 

the graphic as it is exported. This script creates an encapsulated PostScript file. Other output for-

mats are available from the Matlab figure menu. 

% Test Matlab graphics export 
set (0, 'DefaultAxesFontSize', 8, ... 
       , 'Times');  'DefaultAxesFontName'
figure; 
set (gcf, 'Units', 'centimeter'); 
pos = get (gcf, 'Position'); 
pos(3) = 10; 
pos(4) = 8; 
set (gcf, 'Position', pos); 
  
set (gca, 'Units', 'centimeter'); 
set (gca, 'Position', [1.5 1.2 8 6]); 
  
theta=0:2*pi/200:2*pi; 
plot (sin(theta),cos(theta)); 
axis ([0 1.05 -0.2 1.05]); 
xlabel ('\theta_i'); 
ylabel ('amplitude'); 
  
set (gcf, 'PaperPositionMode', 'auto'); 
  
print -depsc SamplePlot.eps; 

Fig. 1  Matlab script to generate a sample plot. 

The figure as it appears on the computer screen is shown in Fig. 2. The gray area delimits 

the figure box and the axes box is the white area contained in the figure box. 

A graphic can be saved to the clipboard by selecting the Edit > Copy Figure from the Matlab 

figure menu. The Edit > Copy Options menus allow one to choose the format (Metafile or bit-
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Fig. 2  Matlab figure as it appears on the computer screen 

map) to be saved to the clipboard as well as the figure background colour.5 Alternately, the figure 

can be saved to a number of different file formats using the Save As dialog. Useful formats for 

importing into Word are PostScript, EMF, BMP, and PNG.. 

4.1 PostScript 

The included file SamplePlot.eps is shown in Fig. 3.6 A screen snapshot of the box contain-

ing the preview that appears in Word is shown in Fig. 4.  

The axes box in the graph is the 8 cm × 6 cm specified in the Matlab script. One can notice 

that the overall size of the plot in Word is smaller than the figure box — the overall size is just big 

enough to contain the plot and the axis annotations. The size of the PostScript file is 9 kB. 

It is to be noted that there is a different behaviour if the Save As option on the figure is used 

to save the plot as a PostScript file. With the Save As method, the bounding box includes the 

whole figure box and so has additional white space around the plot and labels. 

                                                      

5 The background colour can be left as is (gray by default) or forced to be white or transparent. 

6 Each plot in this report is enclosed in ruled box to show the overall size of the plot. 
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Fig. 3  Encapsulated PostScript graphic. 

 
Fig. 4  Word preview of the PostScript graphic. 

4.2 EMF format 

The EMF graphic from the clipboard is shown in Fig. 5. Close inspection of the printed out-

put shows that the curved line is slightly wavy and has an uneven line thickness. By comparison 

the PostScript plots (in the printout) appear smooth and even. Note that this graphic includes the 

entire figure box, resulting in extra white space around the plot (compare with the PostScript fig-

ure above). If the EMF format is saved to a file, the file size is 14 kB. 
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A consequence of the use of the EMF format is that the labels can change if the graphic is 

edited in Word. For instance, selecting Edit Picture (available with a right-click on the EMF 

graphic) causes a conversion of the picture. The vertical label (‘amplitude’) changes to horizontal 

text! 

The extra white space around the graphic can be cropped in Word using the Format Picture 

dialog (Picture tab). 

4.3 Bitmap format 

The bitmap graphic pasted from the clipboard is shown in Fig. 6. The standard bitmap for-

mat (BMP) cannot handle transparency (the figure background has been set to white in Copy Op-

tions). If the bitmap format is saved to a BMP file, the file size is 114 kB. Alternately, a PNG file 

can be used. This bitmap format supports transparency and is compressed. The size of the PNG 

file is 3 kB. The results on the screen and printed page are the same as for the BMP format. Note 

that on the printed page, the rendition for the bitmap graphics is noticeably inferior to that for the 

PostScript (both for the plot curve and the lettering). 
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Fig. 5  EMF graphic from the clipboard. 
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Fig. 6  Bitmap graphic. 
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5 Summary 

The results shown in this report indicate that importing a PostScript figure gives a quality 

that is superior to the other plot formats considered. The results are summarized below. 

• PostScript plots are rendered well in the final printout, though the screen preview is not of 

high quality. The size of the included figure is the same as that specified in Matlab. Post-

Script plots should be created using the Matlab print command and not from the Save As 

menu on the Matlab figure. The former excises the white space surrounding the figure; the 

latter includes the whole figure box. 

• To ensure high-quality printed output on all types of printers, convert the document to PDF 

format before printing if the Word document contains PostScript figures. 

• EMF graphics do not print with as high quality as PostScript graphics do. They include the 

full figure box and so include extra empty space around the graph. 

• Bitmap graphics include the full figure box and so includes extra empty space around the 

graph. The quality of the bitmap graphic is inferior to that of a PostScript figure. 

• For all graphic types except PostScript, the reproduced size of the graphic is the size of the 

Matlab figure box. The graphic can be cropped in Word to eliminate excess white space. 

Appendix A outlines a procedure to include figures and captions. A companion report [2] shows 

the use of Matlab routines to help streamline the production of publication quality graphics. 
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Appendix A Placing Figures in a Word Document 

Word does not provide good mechanisms for inserting “floating” figures. The following in-

dicates a number of steps that can be used to place the graphic and its caption together in a Word 

Frame. Word Frames are boxes which exist in the text layer of the document. That means that the 

figure number in the caption can be referenced from the main text using a cross-reference (Insert 

> Reference > Cross-reference). However, Word does not provide a direct mechanism to create 

a Frame. One must instead create a Text Box (a graphics layer item) first and then convert that 

Text Box to a Frame. 

1. Create some space for the figure and insert the graphic either through Insert > Picture > 

From File or by pasting a figure from the clipboard. 

2. Add a caption: Insert > Reference > Caption. 

3. Select the graphic and the caption. 

4. Enclose the graphic and the caption in a text box: Insert > Text Box. 

5. Right click the text box and select Format Text Box. 

a. Colors and Lines tab: select No Line and No Fill. 

b. Layout tab: select Center. 

c. Advanced button, select Text Wrapping to be Top and bottom. 

d. Text Box tab: select Convert to Frame. 

6. Right click the frame and select Format Frame. 

a. Set the width and height to Auto. 

b. Set the horizontal position to Center relative to Margin. 

The frame has a text anchor which attaches the frame to a paragraph. The frame appears on 

the same page as the text anchor. The vertical position of the frame (Format Frame dialog) can be 

chosen to be relative to the position of the anchor or with respect to the page (for instance placing 

the Vertical Position to be Top relative to the document Margin). One often has to move both the 

anchor and the frame (using the mouse). After moving the frame manually, the horizontal position 

may have to be recentered with the Format Frame dialog. 

Positioning can become tricky when several figures appear close to one another. Consider 

the following steps. Insert enough blank lines (empty paragraphs) to be able to insert the figures 
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separately. Position the first of the group of figures by moving the text anchor and the frame. 

Then start working on the second of the figures, by positioning its text anchor and removing the 

empty paragraphs. 

In this document, two of the figures were placed in a single frame to keep them together for 

easier positioning. The last figure in this report ended up on a page by itself, with its frame an-

chored to a blank paragraph on that otherwise empty page. 
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